Investigating issues with latency
Incident Report for SMATA
Resolved
We’re currently investigating reports of a service interruption related to latency issues. We apologise for any inconvenience and will post another update as soon as we learn more.
Posted Jun 20, 2023 - 23:00 UTC